Logoj0ke.net Open Build Service > Projects > server:monitoring:branches:gearman:1.0.1 > libdbi > libdbi1.spec
Sign Up | Log In

File libdbi1.spec of Package libdbi

 
1
%define     pkgname libdbi
2
%define     soname  1
3
%define     version 0.8.4
4
%define     release 1
5
6
Name:       %{pkgname}%{soname}
7
Version:    %{version}
8
Release:    %{release}
9
Summary:    Database Independent Abstraction Layer for C
10
License:    GPLv2
11
Url:        http://libdbi.sourceforge.net/
12
Group:      Development/Libraries
13
Source0:    %{pkgname}-%{version}.tar.bz2
14
Provides:   %{pkgname}
15
Obsoletes:  %{pkgname}
16
BuildRoot:  %{_tmppath}/%{name}-%{version}-root
17
BuildRequires:  openjade sgmltool texlive docbook-dsssl-stylesheets
18
19
%description
20
libdbi implements a database-independent abstraction layer in C, similar to the DBI/DBD layer in Perl. Writing one generic set of code, programmers can leverage the power of multiple databases and multiple simultaneous database connections by using this framework.
21
22
In order to utilize the libdbi framework, you need to install drivers for a particular type of database. The drivers officially supported by libdbi are split off into the libdbi-drivers project. The current version of libdbi (0.8.3) is supposed to work with any 0.8.x release of libdbi-drivers. Currently the following database engines are supported:
23
24
    * Firebird/Interbase
25
    * FreeTDS (provides access to MS SQL Server and Sybase)
26
    * MySQL
27
    * PostgreSQL
28
    * SQLite/SQLite3
29
30
The following database engines are in preparation:
31
32
    * Ingres
33
    * mSQL
34
    * Oracle
35
36
37
%package -n %{pkgname}-devel
38
Summary:    Devel files for libdbi
39
Group:      Development/Libraries
40
Requires:   %{pkgname}%{soname} = %{version}-%{release}
41
42
%description -n %{pkgname}-devel
43
Header files and development libraries for libdbi
44
45
%prep
46
%setup -n %{pkgname}-%{version}
47
48
49
%build
50
CFLAGS="$RPM_OPT_FLAGS" %configure
51
%{__make}
52
53
%install
54
%{__make} DESTDIR=%{buildroot} install
55
mkdir guides
56
mv %{buildroot}/usr/share/doc/%{pkgname}-%{version}/driver-guide* guides/
57
mv %{buildroot}/usr/share/doc/%{pkgname}-%{version}/programmers-guide* guides/
58
strip %{buildroot}%{_libdir}/%{pkgname}.so.1.0.0
59
60
%clean
61
rm -rf %{buildroot}
62
63
%post -p /sbin/ldconfig
64
65
%postun -p /sbin/ldconfig
66
67
%files
68
%defattr(-,root,root)
69
%doc README
70
%doc guides/
71
%{_libdir}/%{pkgname}.so.1.0.0
72
73
%files -n %{pkgname}-devel
74
%defattr(-,root,root)
75
%dir %{_includedir}/dbi
76
%{_includedir}/dbi/dbd.h
77
%{_includedir}/dbi/dbi-dev.h
78
%{_includedir}/dbi/dbi.h
79
%{_libdir}/%{pkgname}.a
80
%{_libdir}/%{pkgname}.la
81
%{_libdir}/%{pkgname}.so
82
%{_libdir}/%{pkgname}.so.1
83
84
%changelog
85