Search
j0ke.net Open Build Service
>
Projects
>
server:database
:
mongodb
:
2.4
>
mongodb
> mongodb.spec
Sign Up
|
Log In
Username
Password
Cancel
Overview
Repositories
Revisions
Requests
Users
Advanced
Attributes
Meta
File mongodb.spec of Package mongodb (Revision 3)
Currently displaying revision
3
,
show latest
# # spec file for package mongodb # # Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany. # # All modifications and additions to the file contributed by third parties # remain the property of their copyright owners, unless otherwise agreed # upon. The license for this file, and modifications and additions to the # file, is the same license as for the pristine package itself (unless the # license for the pristine package is not an Open Source License, in which # case the license is the MIT License). An "Open Source License" is a # license that conforms to the Open Source Definition (Version 1.9) # published by the Open Source Initiative. # Please submit bugfixes or comments via http://bugs.opensuse.org/ # %define _home_dir %{_var}/lib/%{name} %define _mongodb_user %{name} %define _mongodb_group %{name} Name: mongodb Version: 2.4.8 Release: 0 Url: http://www.mongodb.org Summary: High-performance, schema-free document-oriented database License: AGPL-3.0 and Apache-2.0 Group: Productivity/Databases/Servers Source0: mongodb-src-r%{version}.tar.gz Source1: mongodb.init Source2: mongodb.logrotate Source3: mongodb.conf Patch0: mongodb-no-werror.patch Patch1: void_return.patch # FIX-FOR-UPSTREAM https://jira.mongodb.org/browse/SERVER-5575 - fix the "--full" flag i586 build error. ## Patch2: %{name}-%{version}-mongodb_scons-full-flag.patch # FIX-FOR-UPSTREAM openssl 0.9.8 has no FIPS. Patch3: mongodb-ssl-FIPS_mode_set.patch BuildRequires: boost-devel BuildRequires: fdupes BuildRequires: gcc-c++ BuildRequires: libpcap-devel BuildRequires: libstdc++-devel BuildRequires: openssl-devel BuildRequires: pcre-devel BuildRequires: python-devel >= 2.6 BuildRequires: readline-devel BuildRequires: scons >= 1.1 #BuildRequires: v8-devel Requires: glibc-locale Requires: logrotate Requires(pre): %{fillup_prereq} Requires(pre): %{insserv_prereq} Requires(post): %{insserv_prereq} Requires(pre): pwdutils BuildRoot: %{_tmppath}/%{name}-%{version}-build ExcludeArch: ppc ppc64 s390x %description Mongo (from "humongous") is a high-performance, open source, schema-free document-oriented database. MongoDB is written in C++ and offers the following features: * Collection oriented storage: easy storage of object/JSON-style data * Dynamic queries * Full index support, including on inner objects and embedded arrays * Query profiling * Replication and fail-over support * Efficient storage of binary data including large objects (e.g. photos and videos) * Auto-sharding for cloud-level scalability (currently in early alpha) * Commercial Support Available A key goal of MongoDB is to bridge the gap between key/value stores (which are fast and highly scalable) and traditional RDBMS systems (which are deep in functionality). %package devel Summary: High-performance, schema-free document-oriented database Group: Development/Libraries/C and C++ Requires: %{name} = %{version} %description devel Mongo (from "humongous") is a high-performance, open source, schema-free document-oriented database. This package contains headers and static libraries necessary for development. %prep %setup -q -n mongodb-src-r%{version} %patch0 -p1 %if 0%{?suse_version} < 1120 # strange, maybe, boost::filesystem::remove is void here, and bool later? %patch1 -p1 %endif ## ifarch i586 ## patch2 -p1 ## endif %if 0%{?suse_version} <= 1210 %patch3 -p1 %endif # change dbpath sed -i 's|/data/db/|%{_home_dir}/|' src/mongo/db/pdfile.cpp chmod a-x README %build export CPPFLAGS=$(echo "%{optflags}" | sed "s|-Wall|-Wno-error|") #NOTE(saschpe): Use "system" allocator, tcmalloc isn't packaged yet: scons %{?_smp_mflags} --prefix=%{_prefix} --nostrip --full --ssl \ %if 0%{?suse_version} > 1230 --use-system-boost \ %endif --use-system-pcre %install scons install --prefix=%{buildroot}%{_prefix} install -d -m 0755 \ %{buildroot}%{_sysconfdir}/init.d \ %{buildroot}%{_sysconfdir}/logrotate.d \ %{buildroot}%{_bindir} \ %{buildroot}%{_libdir} \ %{buildroot}%{_sbindir} \ %{buildroot}%{_mandir}/man1 \ %{buildroot}%{_localstatedir}/lib/mongodb \ %{buildroot}%{_localstatedir}/log/mongodb mv %{buildroot}%{_bindir}/mongod %{buildroot}%{_sbindir} install -m 0755 %{SOURCE1} %{buildroot}%{_sysconfdir}/init.d/%{name} ln -sf /etc/init.d/%{name} %{buildroot}%{_sbindir}/rc%{name} install -m 0644 %{SOURCE2} %{buildroot}%{_sysconfdir}/logrotate.d/%{name} install -m 0644 %{SOURCE3} %{buildroot}%{_sysconfdir}/%{name}.conf install -m 0644 debian/*.1 %{buildroot}%{_mandir}/man1/ %ifarch x86_64 mv %{buildroot}%{_prefix}/lib/libmongoclient.a %{buildroot}%{_libdir}/ %endif find %{buildroot}%{_includedir} -type f -name "*.h" -exec chmod -x {} \; %fdupes %{buildroot} %pre /usr/sbin/groupadd -r %{_mongodb_group} >/dev/null 2>/dev/null || : /usr/sbin/useradd -r -g %{_mongodb_group} -c "MongoDB database admin" \ -s /bin/false -d %{_home_dir} %{_mongodb_user} 2> /dev/null || : /usr/sbin/usermod -g %{_mongodb_group} -s /bin/false %{_mongodb_user} || : %post /sbin/ldconfig %{fillup_and_insserv -f %{name}} %preun %{stop_on_removal %{name}} %postun /sbin/ldconfig %{restart_on_update %{name}} %{insserv_cleanup} %files %defattr(-,root,root,-) %doc README GNU-AGPL-3.0.txt APACHE-2.0.txt %config(noreplace) %{_sysconfdir}/logrotate.d/%{name} %config(noreplace) %{_sysconfdir}/%{name}.conf %{_mandir}/man1/* %{_bindir}/bsondump %{_bindir}/mongo* %{_sbindir}/mongod %{_sbindir}/rc%{name} %{_sysconfdir}/init.d/%{name} %attr(0750,mongodb,mongodb) %{_var}/log/mongodb %attr(0750,mongodb,mongodb) %{_var}/lib/mongodb %files devel %defattr(-,root,root,-) %{_includedir}/mongo %{_libdir}/libmongoclient.a %changelog