Search
j0ke.net Open Build Service
>
Projects
>
internetx
:
php5
:
EL5
:
5.4.37
:
extensions
>
php-pecl-ZendOpcache
> php-pecl-ZendOpcache.spec
Sign Up
|
Log In
Username
Password
Cancel
Overview
Repositories
Revisions
Requests
Users
Advanced
Attributes
Meta
File php-pecl-ZendOpcache.spec of Package php-pecl-ZendOpcache
%{!?__pecl: %{expand: %%global __pecl %{_bindir}/pecl}} %{!?php_extdir: %{expand: %%global php_extdir %(php-config --extension-dir)}} %global php_apiver %((echo 0; php -i 2>/dev/null | sed -n 's/^PHP API => //p') | tail -1) %define pecl_name zendopcache %define pecl_so_name opcache Summary: The Zend OPcache provides faster PHP execution through opcode caching and optimization Name: php-pecl-ZendOpcache Provides: php-pecl-zendopcache = %{version}.%{release} Version: 7.0.5 Release: 1%{?dist} License: PHP Group: Development/Languages URL: http://pecl.php.net/package/%{pecl_name} Source: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n) BuildRequires: php-devel >= 4.3.11, php-pear, zlib-devel Requires(post): %{__pecl} Requires(postun): %{__pecl} Provides: php-pecl(%{pecl_name}) = %{version}-%{release} Provides: php-pecl(%{pecl_so_name}) = %{version}-%{release} %if %{defined php_zend_api} Requires: php(zend-abi) = %{php_zend_api} Requires: php(api) = %{php_core_api} %else Requires: php-api = %{php_apiver} %endif %description The Zend OPcache provides faster PHP execution through opcode caching and optimization. It improves PHP performance by storing precompiled script bytecode in the shared memory. This eliminates the stages of reading code from the disk and compiling it on future access. In addition, it applies a few bytecode optimization patterns that make code execution faster. %prep %setup -c -q %build cd %{pecl_name}-%{version} phpize %configure %{__make} %{?_smp_mflags} %install cd %{pecl_name}-%{version} %{__rm} -rf %{buildroot} %{__make} install INSTALL_ROOT=%{buildroot} # Drop in the bit of configuration %{__mkdir_p} %{buildroot}%{_sysconfdir}/php.d %{__cat} > %{buildroot}%{_sysconfdir}/php.d/%{pecl_name}.ini << 'EOF' ; Enable %{pecl_so_name} extension module zend_extension=%{php_extdir}/%{pecl_so_name}.so opcache.memory_consumption=128 opcache.interned_strings_buffer=8 opcache.max_accelerated_files=4000 opcache.revalidate_freq=60 opcache.fast_shutdown=1 opcache.enable_cli=1 EOF # Install XML package description # use 'name' rather than 'pecl_name' to avoid conflict with pear extensions %{__mkdir_p} %{buildroot}%{pecl_xmldir} %{__install} -m 644 ../package.xml %{buildroot}%{pecl_xmldir}/%{name}.xml %clean %{__rm} -rf %{buildroot} %if 0%{?pecl_install:1} %post %{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || : %endif %if 0%{?pecl_uninstall:1} %postun if [ $1 -eq 0 ] ; then %{pecl_uninstall} %{pecl_name} >/dev/null || : fi %endif %files %defattr(-, root, root, -) %doc %{pecl_name}-%{version}/README %config(noreplace) %{_sysconfdir}/php.d/%{pecl_name}.ini %{php_extdir}/%{pecl_so_name}.so %{pecl_xmldir}/%{name}.xml %changelog