File haproxy.spec of Package haproxy (Revision 10)
Currently displaying revision 10, show latest
x
1
Summary: HA-Proxy is a TCP/HTTP reverse proxy for high availability environments
2
Name: haproxy
3
Version: 1.5-dev15
4
Release: 1
5
License: GPL
6
Group: System Environment/Daemons
7
URL: http://haproxy.1wt.eu/
8
Source0: http://haproxy.1wt.eu/download/1.5/src/devel/haproxy-1.5-dev15.tar.gz
9
BuildRoot: %{_tmppath}/haproxy-1.5-dev15-root
10
BuildRequires: pcre-devel
11
Requires: /sbin/chkconfig, /sbin/service
12
13
%description
14
HA-Proxy is a TCP/HTTP reverse proxy which is particularly suited for high
15
availability environments. Indeed, it can:
16
- route HTTP requests depending on statically assigned cookies
17
- spread the load among several servers while assuring server persistence
18
through the use of HTTP cookies
19
- switch to backup servers in the event a main one fails
20
- accept connections to special ports dedicated to service monitoring
21
- stop accepting connections without breaking existing ones
22
- add/modify/delete HTTP headers both ways
23
- block requests matching a particular pattern
24
25
It needs very little resource. Its event-driven architecture allows it to easily
26
handle thousands of simultaneous connections on hundreds of instances without
27
risking the system's stability.
28
29
%prep
30
%setup -q
31
32
# We don't want any perl dependecies in this RPM:
33
%define __perl_requires /bin/true
34
35
%build
36
%{__make} USE_PCRE=1 DEBUG="" ARCH=%{_target_cpu} TARGET=linux26
37
38
%install
39
[ "%{buildroot}" != "/" ] && %{__rm} -rf %{buildroot}
40
41
%{__install} -d %{buildroot}%{_sbindir}
42
%{__install} -d %{buildroot}%{_sysconfdir}/rc.d/init.d
43
%{__install} -d %{buildroot}%{_sysconfdir}/%{name}
44
%{__install} -d %{buildroot}%{_mandir}/man1/
45
46
%{__install} -s %{name} %{buildroot}%{_sbindir}/
47
%{__install} -c -m 644 examples/%{name}.cfg %{buildroot}%{_sysconfdir}/%{name}/
48
%{__install} -c -m 755 examples/%{name}.init %{buildroot}%{_sysconfdir}/rc.d/init.d/%{name}
49
%{__install} -c -m 755 doc/%{name}.1 %{buildroot}%{_mandir}/man1/
50
51
%clean
52
[ "%{buildroot}" != "/" ] && %{__rm} -rf %{buildroot}
53
54
%post
55
/sbin/chkconfig --add %{name}
56
57
%preun
58
if [ $1 = 0 ]; then
59
/sbin/service %{name} stop >/dev/null 2>&1 || :
60
/sbin/chkconfig --del %{name}
61
fi
62
63
%postun
64
if [ "$1" -ge "1" ]; then
65
/sbin/service %{name} condrestart >/dev/null 2>&1 || :
66
fi
67
68
%files
69
%defattr(-,root,root)
70
%doc CHANGELOG TODO examples/*.cfg doc/haproxy-en.txt doc/haproxy-fr.txt doc/architecture.txt doc/configuration.txt
71
%doc %{_mandir}/man1/%{name}.1*
72
73
%attr(0755,root,root) %{_sbindir}/%{name}
74
%dir %{_sysconfdir}/%{name}
75
%attr(0644,root,root) %config(noreplace) %{_sysconfdir}/%{name}/%{name}.cfg
76
%attr(0755,root,root) %config %{_sysconfdir}/rc.d/init.d/%{name}
77
78
%changelog
79
* Wed Dec 12 2012 Willy Tarreau <w@1wt.eu>
80
- updated to 1.5-dev15
81
82
* Mon Nov 26 2012 Willy Tarreau <w@1wt.eu>
83
- updated to 1.5-dev14
84
85
* Thu Nov 22 2012 Willy Tarreau <w@1wt.eu>
86
- updated to 1.5-dev13
87
88
* Mon Sep 10 2012 Willy Tarreau <w@1wt.eu>
89
- updated to 1.5-dev12
90
91
* Mon Jun 4 2012 Willy Tarreau <w@1wt.eu>
92
- updated to 1.5-dev11
93
94
* Mon May 14 2012 Willy Tarreau <w@1wt.eu>
95
- updated to 1.5-dev10
96
97
* Tue May 8 2012 Willy Tarreau <w@1wt.eu>
98
- updated to 1.5-dev9
99
100
* Mon Mar 26 2012 Willy Tarreau <w@1wt.eu>
101
- updated to 1.5-dev8
102
103
* Sat Sep 10 2011 Willy Tarreau <w@1wt.eu>
104
- updated to 1.5-dev7
105
106
* Fri Apr 8 2011 Willy Tarreau <w@1wt.eu>
107
- updated to 1.5-dev6
108
109
* Tue Mar 29 2011 Willy Tarreau <w@1wt.eu>
110
- updated to 1.5-dev5
111
112
* Sun Mar 13 2011 Willy Tarreau <w@1wt.eu>
113
- updated to 1.5-dev4
114
115
* Thu Nov 11 2010 Willy Tarreau <w@1wt.eu>
116
- updated to 1.5-dev3
117
118
* Sat Aug 28 2010 Willy Tarreau <w@1wt.eu>
119
- updated to 1.5-dev2
120
121
* Wed Aug 25 2010 Willy Tarreau <w@1wt.eu>
122
- updated to 1.5-dev1
123
124
* Sun May 23 2010 Willy Tarreau <w@1wt.eu>
125
- updated to 1.5-dev0
126
127
* Sun May 16 2010 Willy Tarreau <w@1wt.eu>
128
- updated to 1.4.6
129
130
* Thu May 13 2010 Willy Tarreau <w@1wt.eu>
131
- updated to 1.4.5
132
133
* Wed Apr 7 2010 Willy Tarreau <w@1wt.eu>
134
- updated to 1.4.4
135
136
* Tue Mar 30 2010 Willy Tarreau <w@1wt.eu>
137
- updated to 1.4.3
138
139
* Wed Mar 17 2010 Willy Tarreau <w@1wt.eu>
140
- updated to 1.4.2
141
142
* Thu Mar 4 2010 Willy Tarreau <w@1wt.eu>
143
- updated to 1.4.1
144
145
* Fri Feb 26 2010 Willy Tarreau <w@1wt.eu>
146
- updated to 1.4.0
147
148
* Tue Feb 2 2010 Willy Tarreau <w@1wt.eu>
149
- updated to 1.4-rc1
150
151
* Mon Jan 25 2010 Willy Tarreau <w@1wt.eu>
152
- updated to 1.4-dev8
153
154
* Mon Jan 25 2010 Willy Tarreau <w@1wt.eu>
155
- updated to 1.4-dev7
156
157
* Fri Jan 8 2010 Willy Tarreau <w@1wt.eu>
158
- updated to 1.4-dev6
159
160
* Sun Jan 3 2010 Willy Tarreau <w@1wt.eu>
161
- updated to 1.4-dev5
162
163
* Mon Oct 12 2009 Willy Tarreau <w@1wt.eu>
164
- updated to 1.4-dev4
165
166
* Thu Sep 24 2009 Willy Tarreau <w@1wt.eu>
167
- updated to 1.4-dev3
168
169
* Sun Aug 9 2009 Willy Tarreau <w@1wt.eu>
170
- updated to 1.4-dev2
171
172
* Wed Jul 29 2009 Willy Tarreau <w@1wt.eu>
173
- updated to 1.4-dev1
174
175
* Tue Jun 09 2009 Willy Tarreau <w@1wt.eu>
176
- updated to 1.4-dev0
177
178
* Sun May 10 2009 Willy Tarreau <w@1wt.eu>
179
- updated to 1.3.18
180
181
* Sun Mar 29 2009 Willy Tarreau <w@1wt.eu>
182
- updated to 1.3.17
183
184
* Sun Mar 22 2009 Willy Tarreau <w@1wt.eu>
185
- updated to 1.3.16
186
187
* Sat Apr 19 2008 Willy Tarreau <w@1wt.eu>
188
- updated to 1.3.15
189
190
* Wed Dec 5 2007 Willy Tarreau <w@1wt.eu>
191
- updated to 1.3.14
192
193
* Thu Oct 18 2007 Willy Tarreau <w@1wt.eu>
194
- updated to 1.3.13
195
196
* Sun Jun 17 2007 Willy Tarreau <w@1wt.eu>
197
- updated to 1.3.12
198
199
* Sun Jun 3 2007 Willy Tarreau <w@1wt.eu>
200
- updated to 1.3.11.4
201
202
* Mon May 14 2007 Willy Tarreau <w@1wt.eu>
203
- updated to 1.3.11.3
204
205
* Mon May 14 2007 Willy Tarreau <w@1wt.eu>
206
- updated to 1.3.11.2
207
208
* Mon May 14 2007 Willy Tarreau <w@1wt.eu>
209
- updated to 1.3.11.1
210
211
* Mon May 14 2007 Willy Tarreau <w@1wt.eu>
212
- updated to 1.3.11
213
214
* Thu May 10 2007 Willy Tarreau <w@1wt.eu>
215
- updated to 1.3.10.2
216
217
* Tue May 09 2007 Willy Tarreau <w@1wt.eu>
218
- updated to 1.3.10.1
219
220
* Tue May 08 2007 Willy Tarreau <w@1wt.eu>
221
- updated to 1.3.10
222
223
* Sun Apr 15 2007 Willy Tarreau <w@1wt.eu>
224
- updated to 1.3.9
225
226
* Tue Apr 03 2007 Willy Tarreau <w@1wt.eu>
227
- updated to 1.3.8.2
228
229
* Sun Apr 01 2007 Willy Tarreau <w@1wt.eu>
230
- updated to 1.3.8.1
231
232
* Sun Mar 25 2007 Willy Tarreau <w@1wt.eu>
233
- updated to 1.3.8
234
235
* Wed Jan 26 2007 Willy Tarreau <w@1wt.eu>
236
- updated to 1.3.7
237
238
* Wed Jan 22 2007 Willy Tarreau <w@1wt.eu>
239
- updated to 1.3.6
240
241
* Wed Jan 07 2007 Willy Tarreau <w@1wt.eu>
242
- updated to 1.3.5
243
244
* Wed Jan 02 2007 Willy Tarreau <w@1wt.eu>
245
- updated to 1.3.4
246
247
* Wed Oct 15 2006 Willy Tarreau <w@1wt.eu>
248
- updated to 1.3.3
249
250
* Wed Sep 03 2006 Willy Tarreau <w@1wt.eu>
251
- updated to 1.3.2
252
253
* Wed Jul 09 2006 Willy Tarreau <w@1wt.eu>
254
- updated to 1.3.1
255
256
* Wed May 21 2006 Willy Tarreau <willy@w.ods.org>
257
- updated to 1.2.14
258
259
* Wed May 01 2006 Willy Tarreau <willy@w.ods.org>
260
- updated to 1.2.13
261
262
* Wed Apr 15 2006 Willy Tarreau <willy@w.ods.org>
263
- updated to 1.2.12
264
265
* Wed Mar 30 2006 Willy Tarreau <willy@w.ods.org>
266
- updated to 1.2.11.1
267
268
* Wed Mar 19 2006 Willy Tarreau <willy@w.ods.org>
269
- updated to 1.2.10
270
271
* Wed Mar 15 2006 Willy Tarreau <willy@w.ods.org>
272
- updated to 1.2.9
273
274
* Sat Jan 22 2005 Willy Tarreau <willy@w.ods.org>
275
- updated to 1.2.3 (1.1.30)
276
277
* Sun Nov 14 2004 Willy Tarreau <w@w.ods.org>
278
- updated to 1.1.29
279
- fixed path to config and init files
280
- statically linked PCRE to increase portability to non-pcre systems
281
282
* Sun Jun 6 2004 Willy Tarreau <willy@w.ods.org>
283
- updated to 1.1.28
284
- added config check support to the init script
285
286
* Tue Oct 28 2003 Simon Matter <simon.matter@invoca.ch>
287
- updated to 1.1.27
288
- added pid support to the init script
289
290
* Wed Oct 22 2003 Simon Matter <simon.matter@invoca.ch>
291
- updated to 1.1.26
292
293
* Thu Oct 16 2003 Simon Matter <simon.matter@invoca.ch>
294
- initial build
295