File nrpe.spec of Package nrpe3 (Revision 1922e52e970753d06c6dfc98871a9bec)
Currently displaying revision 1922e52e970753d06c6dfc98871a9bec, show latest
1
%if 0%{?fedora} > 19
2
%global _hardened_build 1
3
%endif
4
%define nsport 5666
5
%define myname nrpe
6
%define nsusr nagios
7
%define nsgrp nagios
8
9
Name: nagios-%{myname}
10
Version: 3.2.1
11
Release: 9%{?dist}
12
Summary: Host/service/network monitoring agent for Nagios
13
14
License: GPLv2
15
URL: http://www.nagios.org
16
Source0: https://github.com/NagiosEnterprises/nrpe/archive/%{myname}-%{version}.tar.gz
17
Source1: nrpe.sysconfig
18
Source2: nrpe-tmpfiles.conf
19
Source3: nrpe.README.SELinux.rst
20
Source4: nrpe_epel6.te
21
Source5: nrpe_epel7.te
22
Source6: nrpe_epel.fc
23
Source7: nrpe.service.epel
24
Source8: nrpe.xinetd
25
26
Patch3: nrpe-0003-Include-etc-npre.d-config-directory.patch
27
Patch4: nrpe-default-config.patch
28
Patch13: nrpe-0013-service-rhel6.patch
29
30
# For reconfiguration
31
BuildRequires: autoconf, automake, libtool
32
BuildRequires: gcc
33
BuildRequires: openssl, openssl-devel
34
BuildRequires: checkpolicy, selinux-policy-devel
35
%if 0%{?fedora} > 17 || 0%{?rhel} > 6
36
BuildRequires: systemd-units
37
%endif
38
39
%if 0%{?fedora} < 28 && 0%{?rhel} < 8
40
BuildRequires: tcp_wrappers-devel
41
%endif
42
43
Requires(pre): %{_sbindir}/useradd, %{_sbindir}/usermod
44
45
%if 0%{?el6}
46
Requires(preun): /sbin/service, /sbin/chkconfig
47
Requires(post): /sbin/chkconfig, /sbin/service
48
Requires(postun): /sbin/service
49
Requires: initscripts
50
%else
51
Requires(post): systemd
52
Requires(preun): systemd
53
Requires(postun): systemd
54
%endif
55
56
# owns /etc/nagios
57
Requires: nagios-plugins
58
Provides: nagios-nrpe = %{version}-%{release}
59
60
%description
61
Nrpe is a system daemon that will execute various Nagios plugins
62
locally on behalf of a remote (monitoring) host that uses the
63
check_nrpe plugin. Various plugins that can be executed by the
64
daemon are available at:
65
http://sourceforge.net/projects/nagiosplug
66
67
This package provides the core agent.
68
69
%package -n nagios-plugins-nrpe3
70
Summary: Provides nrpe plugin for Nagios
71
Requires: nagios-plugins
72
Provides: check_nrpe = %{version}-%{release}
73
74
%description -n nagios-plugins-nrpe3
75
Nrpe is a system daemon that will execute various Nagios plugins
76
locally on behalf of a remote (monitoring) host that uses the
77
check_nrpe plugin. Various plugins that can be executed by the
78
daemon are available at:
79
http://sourceforge.net/projects/nagiosplug
80
81
This package provides the nrpe plugin for Nagios-related applications.
82
83
%if 0%{?rhel} > 5
84
%package selinux
85
Summary: SELinux context for %{myname}
86
Requires: %name = %version-%release
87
Requires(post): policycoreutils
88
Requires(postun): policycoreutils
89
90
91
%description selinux
92
SElinux context for %{myname}.
93
%endif
94
95
%prep
96
%setup -q -n %{myname}-%{version}
97
%patch3 -p1 -b .include_etc_npre_d
98
%patch4 -p0 -b .default-config-nrpe
99
%patch13 -p1 -b .fix_service_rhel6
100
101
102
%build
103
CFLAGS="$RPM_OPT_FLAGS" CXXFLAGS="$RPM_OPT_FLAGS" LDFLAGS="%{?__global_ldflags}" \
104
%configure \
105
--with-init-dir=%{_initrddir} \
106
--with-nrpe-port=%{nsport} \
107
--with-nrpe-user=%{nsusr} \
108
--with-nrpe-group=%{nsgrp} \
109
--with-piddir=/var/run/nrpe \
110
--bindir=%{_sbindir} \
111
--libdir=/doesnt/matter/ \
112
--libexecdir=%{_prefix}/lib/nagios/plugins \
113
--datadir=%{_datadir}/nagios \
114
--sysconfdir=%{_sysconfdir}/nagios \
115
--localstatedir=%{_localstatedir}/run/ \
116
--enable-command-args
117
118
make %{?_smp_mflags} all
119
120
%if 0%{?rhel} > 5
121
## SELinux configs
122
mkdir selinux
123
install -pm 644 %{SOURCE3} README.SELinux.rst
124
%if 0%{?rhel} < 7
125
cp -p %{SOURCE4} selinux/%{myname}_epel.te
126
%else
127
cp -p %{SOURCE5} selinux/%{myname}_epel.te
128
%endif
129
cp -p %{SOURCE6} selinux/%{myname}_epel.fc
130
touch selinux/%{myname}_epel.if
131
make -f %{_datadir}/selinux/devel/Makefile
132
%endif
133
134
%install
135
rm -rf %{buildroot}
136
%if 0%{?el6}%{?el7}
137
## If we are EL6 we want the old style sysV init script
138
%if 0%{?el6}
139
install -D -p -m 0755 startup/default-init %{buildroot}/%{_initrddir}/nrpe
140
%else
141
## If we are EL7 we want the home crafted systemd service due to problems
142
install -D -m 0644 -p %{SOURCE7} %{buildroot}%{_unitdir}/%{myname}.service
143
%endif
144
%else
145
## If we are Fedora we want the upstream systemd service file
146
install -D -m 0644 -p startup/default-service %{buildroot}%{_unitdir}/%{myname}.service
147
%endif
148
install -D -p -m 0644 sample-config/nrpe.cfg %{buildroot}/%{_sysconfdir}/nagios/%{myname}.cfg
149
install -D -p -m 0755 src/nrpe %{buildroot}/%{_sbindir}/nrpe
150
install -D -p -m 0755 src/check_nrpe %{buildroot}/%{_prefix}/lib/nagios/plugins/check_nrpe3
151
install -D -p -m 0644 %{SOURCE1} %{buildroot}/%{_sysconfdir}/sysconfig/%{myname}
152
install -d %{buildroot}%{_sysconfdir}/nrpe.d
153
install -d %{buildroot}%{_sysconfdir}/nagios/nrpe.d
154
install -d %{buildroot}%{_localstatedir}/run/%{myname}
155
%if 0%{?fedora} > 14 || 0%{?rhel} > 6
156
install -D -p -m 0644 %{SOURCE2} %{buildroot}%{_tmpfilesdir}/%{myname}.conf
157
%endif
158
%if 0%{?rhel} >5
159
# Selinux configs
160
install -p -m 644 -D %{myname}_epel.pp $RPM_BUILD_ROOT%{_datadir}/selinux/packages/%{myname}/%{myname}_epel.pp
161
%endif
162
install -d -m 0755 ${RPM_BUILD_ROOT}/etc/xinetd.d
163
install -m 644 %{SOURCE8} ${RPM_BUILD_ROOT}/etc/xinetd.d/nrpe
164
165
%pre
166
getent group %{nsgrp} >/dev/null || groupadd -r %{nsgrp}
167
getent passwd %{nsusr} >/dev/null || \
168
%{_sbindir}/useradd -c "NRPE user for the NRPE service" -d %{_localstatedir}/run/%{myname} -r -g %{nsgrp} -s /sbin/nologin %{nsusr} 2> /dev/null || :
169
getent group %{nsgrp} >/dev/null && %{_sbindir}/usermod -a -G %{nsgrp} %{nsusr} || :
170
171
%preun
172
%if 0%{?el6}
173
if [ $1 = 0 ]; then
174
/sbin/service %{myname} stop > /dev/null 2>&1 || :
175
/sbin/chkconfig --del %{myname} || :
176
fi
177
%else
178
%systemd_preun nrpe.service
179
%endif
180
181
%post
182
%if 0%{?el6}
183
/sbin/chkconfig --add %{myname} || :
184
%else
185
%systemd_post nrpe.service
186
%endif
187
if [ -d /etc/sudoers.d ] ; then
188
cat > /etc/sudoers.d/50_nagios << EOF
189
nagios ALL=(ALL) NOPASSWD: /usr/lib/nagios/plugins/,/usr/lib64/nagios/plugins/
190
Defaults:nagios !requiretty
191
Defaults:nagios !env_keep
192
EOF
193
chmod 0440 /etc/sudoers.d/50_nagios
194
195
elif [ -f /etc/sudoers ] ; then
196
if [ -z "`grep ^nagios /etc/sudoers`" ] ; then
197
echo "nagios ALL=(ALL) NOPASSWD: /usr/lib/nagios/plugins/,/usr/lib64/nagios/plugins/" >> /etc/sudoers
198
fi
199
if [ -z "`grep ^Defaults:nagios`" ] ; then
200
echo "Defaults:nagios !requiretty" >> /etc/sudoers
201
echo "Defaults:nagios !env_keep" >> /etc/sudoers
202
fi
203
fi
204
205
%postun
206
%if 0%{?el6}
207
if [ "$1" -ge "1" ]; then
208
/sbin/service %{myname} condrestart > /dev/null 2>&1 || :
209
fi
210
%else
211
%systemd_postun_with_restart nrpe.service
212
%endif
213
214
%if 0%{?rhel} >5
215
%post selinux
216
%if 0%{?el6}
217
if [ "$1" -le "1" ]; then # Fist install
218
semodule -i %{_datadir}/selinux/packages/%{myname}/%{myname}_epel.pp 2>/dev/null || :
219
fixfiles -R %{name} restore || :
220
/sbin/service %{myname} condrestart > /dev/null 2>&1 || :
221
fi
222
%else
223
if [ "$1" -le "1" ]; then # Fist install
224
semodule -i %{_datadir}/selinux/packages/%{myname}/%{myname}_epel.pp 2>/dev/null || :
225
fixfiles -R %{name} restore || :
226
%systemd_postun_with_restart %{myname}.service
227
fi
228
%endif
229
%endif
230
231
%if 0%{?rhel} >5
232
%preun selinux
233
%if 0%{?el6}
234
if [ "$1" -lt "1" ]; then # Final removal
235
semodule -r %{myname}_epel 2>/dev/null || :
236
fixfiles -R %{name} restore || :
237
/sbin/service %{myname} condrestart > /dev/null 2>&1 || :
238
fi
239
%else
240
if [ "$1" -lt "1" ]; then # Final removal
241
semodule -r %{myname}_epel 2>/dev/null || :
242
fixfiles -R %{name} restore || :
243
%systemd_postun_with_restart %{myname}.service
244
fi
245
%endif
246
%endif
247
248
%if 0%{?rhel} >5
249
%postun selinux
250
if [ "$1" -ge "1" ]; then # Upgrade
251
# Replaces the module if it is already loaded
252
semodule -i %{_datadir}/selinux/packages/%{myname}/%{myname}_epel.pp 2>/dev/null || :
253
# no need to restart the daemon
254
fi
255
%endif
256
257
%files
258
%if 0%{?el6}
259
%{_initrddir}/nrpe
260
%else
261
%{_unitdir}/%{myname}.service
262
%endif
263
%config(noreplace) %{_sysconfdir}/xinetd.d/nrpe
264
%{_sbindir}/nrpe
265
%dir %{_sysconfdir}/nrpe.d
266
%dir %{_sysconfdir}/nagios/nrpe.d
267
%config(noreplace) %{_sysconfdir}/nagios/nrpe.cfg
268
%config(noreplace) %{_sysconfdir}/sysconfig/%{myname}
269
%if 0%{?fedora} > 14 || 0%{?rhel} > 6
270
%config(noreplace) %{_tmpfilesdir}/%{myname}.conf
271
%endif
272
%doc CHANGELOG.md LICENSE.md LEGAL README.md README.SSL.md SECURITY.md docs/NRPE.pdf
273
%dir %attr(775, %{nsusr}, %{nsgrp}) %{_localstatedir}/run/%{myname}
274
275
%files -n nagios-plugins-nrpe3
276
%{_prefix}/lib/nagios/plugins/check_nrpe3
277
%doc CHANGELOG.md LICENSE.md LEGAL README.md
278
279
%if 0%{?rhel} > 5
280
%files selinux
281
%doc README.SELinux.rst
282
%{_datadir}/selinux/packages/%{myname}/%{myname}_epel.pp
283
%endif
284
285
%changelog
286
* Fri Jul 26 2019 Stephen Smoogen <smooge@fedoraproject.org> - 3.2.1-9
287
- Try to make this work on el8
288
289
* Thu Jul 25 2019 Fedora Release Engineering <releng@fedoraproject.org> - 3.2.1-8
290
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
291
292
* Fri Feb 01 2019 Fedora Release Engineering <releng@fedoraproject.org> - 3.2.1-7
293
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
294
295
* Tue Jul 24 2018 Stephen Smoogen <smooge@fedoraproject.org> - 3.2.1-6
296
- Fix BZ#1546264
297
- Fix potential FTBFS for gcc
298
299
* Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 3.2.1-5
300
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
301
302
* Thu Mar 22 2018 Stephen Smoogen <smooge@fedoraproject.org> - 3.2.1-4
303
- Remove other el5 items. Update spec
304
305
* Fri Feb 09 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 3.2.1-3
306
- Escape macros in %%changelog
307
308
* Thu Feb 08 2018 Fedora Release Engineering <releng@fedoraproject.org> - 3.2.1-2
309
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
310
311
* Tue Nov 21 2017 Stephen Smoogen <smooge@fedoraproject.org> - 3.2.1-1
312
- Update to nrpe-3.2.1
313
- Fix BZ#1485361
314
315
* Fri Aug 4 2017 Stephen Smoogen <smooge@fedoraproject.org> - 3.2.0-6
316
- Found the problem. Fixed and ready to push
317
318
* Fri Aug 4 2017 Stephen Smoogen <smooge@fedoraproject.org> - 3.2.0-5
319
- Make sure nrpe works with different selinux names between 5,6 and 7
320
- For some reason the selinux module still does not install unless by force on EL6.
321
322
* Thu Aug 03 2017 Fedora Release Engineering <releng@fedoraproject.org> - 3.2.0-6
323
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
324
325
* Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 3.2.0-5
326
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
327
328
* Fri Jul 21 2017 Stephen Smoogen <smooge@fedoraproject.org> - 3.2.0-4
329
- Forgot to up the release.
330
331
* Fri Jul 21 2017 Stephen Smoogen <smooge@fedoraproject.org> - 3.2.0-3
332
- Clean out nrpe.fc as that breaks silently
333
334
* Wed Jul 19 2017 Stephen Smoogen <smooge@fedoraproject.org> - 3.2.0-3
335
- Remove git from release name
336
- Fix selinux lines.
337
338
* Fri Jul 14 2017 Stephen Smoogen <smooge@fedoraproject.org> - 3.2.0-2git
339
- Remember to put in a patch so the /etc/nrpe.d/ is used.
340
341
* Fri Jul 14 2017 Stephen Smoogen <smooge@fedoraproject.org> - 3.2.0-1
342
- Update to 3.2.0
343
- Add patches for 321 openssl items
344
- Remove old patches no longer needed
345
346
* Tue Jul 11 2017 Stephen Smoogen <smooge@fedoraproject.org> - 3.1.1-6
347
- Put in fix for 1204683
348
349
* Tue Jul 11 2017 Stephen Smoogen <smooge@fedoraproject.org> - 3.1.1-5
350
- Add comments to nrpe.cfg to alert user on RHBZ #1318773
351
- Backport ipv6 patch for problem
352
353
* Fri Jul 7 2017 Stephen Smoogen <smooge@fedoraproject.org> - 3.1.1-4
354
- Fix patch name. Silly human. Do a fedpkg srpm before build.
355
356
* Fri Jul 7 2017 Stephen Smoogen <smooge@fedoraproject.org> - 3.1.1-3
357
- Fix crashing bug if username is not defined.
358
359
* Wed Jul 5 2017 Stephen Smoogen <smooge@fedoraproject.org> - 3.1.1-2
360
- Fix bug due to /etc/nrpe.d/ includes was above other defined entries BZ# 1467971
361
- I am not updating to 3.2.0 for a bit in order to smush out problems here.
362
363
* Wed Jun 14 2017 Stephen Smoogen <smooge@fedoraproject.org> - 3.1.1-1
364
- Update to 3.1.1
365
- Remove git patch
366
- Add pid_dir configure statement.
367
368
* Tue May 2 2017 Stephen Smoogen <smooge@fedoraproject.org> - 3.1.0-3
369
- Grab updates from upstream to see why nrpe fails on fedora but not rhel
370
371
* Wed Apr 26 2017 Stephen Smoogen <smooge@fedoraproject.org> - 3.1.0-2
372
- Move to using original nirik nrpe service file for systemd. It worked and the others dont
373
- NRPE fails to run using a /var/run/nrpe/ directory so trying to build without it.
374
375
* Thu Apr 20 2017 Stephen Smoogen <smooge@fedoraproject.org> - 3.1.0-1
376
- update to 3.1.0
377
- put in fix for format-error
378
- remove patches not needed.
379
380
* Thu Mar 23 2017 Stephen Smoogen <smooge@fedoraproject.org> - 3.0.1-6
381
- Redo the nagios policy to lower its all the permissions.
382
383
* Wed Mar 22 2017 Stephen Smoogen <smooge@fedoraproject.org> - 3.0.1-5
384
- Put in patches from GIT to fix noise problems
385
- Put in patch for RHEL6 systems to regain vars
386
- Put in initial patch for selinux on EPEL
387
- Remove el4 macros as this won't work there anyway.
388
389
* Fri Mar 3 2017 Stephen Smoogen <smooge@fedoraproject.org> - 3.0.1-5
390
- Remember to add the patch so it can build.
391
392
* Fri Mar 3 2017 Stephen Smoogen <smooge@fedoraproject.org> - 3.0.1-4
393
- Fix systemd to use correct service file.
394
- Add reload rule
395
396
* Fri Mar 3 2017 Stephen Smoogen <smooge@fedoraproject.org> - 3.0.1-3
397
- fix the systemd service file to better match needs.
398
399
* Fri Mar 3 2017 Stephen Smoogen <smooge@fedoraproject.org> - 3.0.1-2
400
- fix the statedir to look at /var/run/nrpe
401
402
* Mon Feb 6 2017 Stephen Smoogen <smooge@fedoraproject.org> - 3.0.1-1
403
- Update to 3.0.1
404
- Add a temp patch to get it to work with openssl v110 for F25
405
406
* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 2.15-8
407
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
408
409
* Tue Sep 8 2015 Peter Robinson <pbrobinson@fedoraproject.org> 2.15-7
410
- Use %%configure macro as it deals with config.sub/guess and various flags properly
411
412
* Fri Sep 04 2015 Scott Wilkerson <swilkerson@fedoraproject.org> - 2.15-6
413
- Fix spec file for missing /usr/share/libtool/config/config.guess
414
415
* Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.15-5
416
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
417
418
* Sun Aug 17 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.15-4
419
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
420
421
* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.15-3
422
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
423
424
* Thu May 1 2014 Sam Kottler <skottler@fedoraproject.org> - 2.15.2
425
- Add patch to mitigate CVE-2014-2913
426
427
* Mon Jan 27 2014 Sam Kottler <skottler@fedoraproject.org> - 2.15.1
428
- Update to 2.15
429
430
* Wed Oct 16 2013 Peter Lemenkov <lemenkov@gmail.com> - 2.14-5
431
- Allow building for aarch64 (rhbz #926244)
432
- Allow user to redefine default commands (rhbz #963703)
433
434
* Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.14-4
435
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
436
437
* Wed May 22 2013 Kevin Fenzi <kevin@scrye.com> 2.14-3
438
- Apply patch from bug 860988 to handle RHEL versions and systemd
439
- Apply patch from bug 957567 to fix condrestart so nrpe restarts on upgrade.
440
- Rework systemd and service scriptlets and requires.
441
- Harden Fedora 19+ builds
442
443
* Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.14-2
444
- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
445
446
* Mon Jan 14 2013 Mark Chappell <tremble@tremble.org.uk> - 2.14
447
- Version 2.14
448
449
* Mon Jan 14 2013 Mark Chappell <tremble@tremble.org.uk> - 2.13-2
450
- #860982 Mistake in service file
451
- #860985 nrpe shouldn't own /etc/nagios (from nagios-common)
452
453
* Mon Sep 17 2012 Peter Lemenkov <lemenkov@gmail.com> - 2.13-1
454
- Ver. 2.13
455
456
* Fri Jul 20 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.12-21
457
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
458
459
* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.12-20
460
- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
461
462
* Thu Sep 22 2011 Peter Lemenkov <lemenkov@gmail.com> - 2.12-19
463
- Disable systemd stuff in EPEL
464
465
* Sat Sep 17 2011 Ruben Kerkhof <ruben@rubenkerkhof.com> - 2.12-18
466
- Let systemd create /var/run/nrpe. Fixes rhbz #656641
467
468
* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.12-17
469
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
470
471
* Mon Oct 25 2010 Peter Lemenkov <lemenkov@gmail.com> - 2.12-16
472
- Issue with SELinux was resolved (see rhbz #565220#c25). 2nd try.
473
474
* Wed Sep 29 2010 jkeating - 2.12-15
475
- Rebuilt for gcc bug 634757
476
477
* Sat Sep 11 2010 Peter Lemenkov <lemenkov@gmail.com> - 2.12-14
478
- Issue with SELinux was resolved (see rhbz #565220).
479
480
* Fri Jun 18 2010 Peter Lemenkov <lemenkov@gmail.com> - 2.12-13
481
- Init-script enhancements (see rhbz #247001, #567141 and #575544)
482
483
* Mon Oct 26 2009 Peter Lemenkov <lemenkov@gmail.com> - 2.12-12
484
- Do not own %%{_libdir}/nagios/plugins ( bz# 528974 )
485
- Fixed building against tcp_wrappers in Fedora ( bz# 528974 )
486
487
* Thu Sep 24 2009 Peter Lemenkov <lemenkov@gmail.com> - 2.12-11
488
- Fixed BZ# 515324
489
490
* Fri Aug 21 2009 Tomas Mraz <tmraz@redhat.com> - 2.12-10
491
- rebuilt with new openssl
492
493
* Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.12-9
494
- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
495
496
* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.12-8
497
- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
498
499
* Sat Feb 21 2009 Mike McGrath <mmcgrath@redhat.com> - 2.12-7
500
- Re-fix for 477527
501
502
* Mon Feb 2 2009 Peter Lemenkov <lemenkov@gmail.com> - 2.12-6
503
- Fixed BZ# 449174
504
- Clean up (in order to disable rpmlint warnings)
505
506
* Sat Jan 17 2009 Tomas Mraz <tmraz@redhat.com> - 2.12-5
507
- rebuild with new openssl
508
509
* Sun Dec 21 2008 Mike McGrath <mmcgrath@redhat.com> - 2.12-4
510
- Added some doc lines for ticket 477527
511
512
* Fri Dec 19 2008 Mike McGrath <mmcgrath@redhat.com> - 2.12-3
513
- Added Provides: nagios-nrpe
514
515
* Fri Dec 19 2008 Mike McGrath <mmcgrath@redhat.com> - 2.12-2
516
- Upstreamreleased new version
517
518
* Tue Feb 12 2008 Mike McGrath <mmcgrath@redhat.com> - 2.7-6
519
- Rebuild for gcc43
520
521
* Wed Dec 05 2007 Release Engineering <rel-eng at fedoraproject dot org> - 2.7-5
522
- Rebuild for deps
523
524
* Wed Aug 22 2007 Mike McGrath <mmcgrath@redhat.com> 2.7-4
525
- License Change
526
- Rebuild for BuildID
527
528
* Fri Feb 23 2007 Mike McGrath <mmcgrath@redhat.com> 2.7-1
529
- Upstream released new version
530
531
* Sun Jul 23 2006 Mike McGrath <imlinux@gmail.com> 2.5.2-3
532
- no longer owns libdir/nagios
533
- buildrequires tcp_wrappers
534
535
* Sun Jul 23 2006 Mike McGrath <imlinux@gmail.com> 2.5.2-2
536
- Specify bogus libdir so rpmlint won't complain
537
538
* Mon Jul 03 2006 Mike McGrath <imlinux@gmail.com> 2.5.2-1
539
- Upstream released new version
540
541
* Sun Mar 12 2006 Mike McGrath <imlinux@gmail.com> 2.4-3
542
- Added description to useradd statement
543
544
* Sun Mar 05 2006 Mike McGrath <imlinux@gmail.com> 2.4-2
545
- Added proper SMP build flags
546
- Added %%{?dist} tag
547
- Added reload to nrpe script
548
- Updated to 2.4, changes include:
549
- Added option to allow week random seed (Gerhard Lausser)
550
- Added optional command line prefix (Sean Finney)
551
- Added ability to reload config file with SIGHUP
552
- Fixed bug with location of dh.h include file
553
- Fixed bug with disconnect message in debug mode
554
555
* Sat Feb 04 2006 Mike McGrath <imlinux@gmail.com> 2.3-1
556
- Created a Fedora friendly spec file
557
558
* Mon Jan 23 2006 Andreas Kasenides ank<@>cs.ucy.ac.cy
559
- fixed nrpe.cfg relocation to sample-config
560
- replaced Copyright label with License
561
- added --enable-command-args to enable remote arg passing (if desired can be disabled by commenting out)
562
563
* Wed Nov 12 2003 Ingimar Robertsson <iar@skyrr.is>
564
- Added adding of nagios group if it does not exist.
565
566
* Tue Jan 07 2003 James 'Showkilr' Peterson <showkilr@showkilr.com>
567
- Removed the lines which removed the nagios user and group from the system
568
- changed the patch release version from 3 to 1
569
570
* Mon Jan 06 2003 James 'Showkilr' Peterson <showkilr@showkilr.com>
571
- Removed patch files required for nrpe 1.5
572
- Update spec file for version 1.6 (1.6-1)
573
574
* Sat Dec 28 2002 James 'Showkilr' Peterson <showkilr@showkilr.com>
575
- First RPM build (1.5-1)
576