File serdisplib.spec of Package serdisplib (Revision 8)
Currently displaying revision 8, show latest
1
#
2
# spec file for package serdisplib (Version 1.97.7)
3
#
4
# Copyright (c) 2007 SUSE LINUX Products GmbH, Nuernberg, Germany.
5
# This file and all modifications and additions to the pristine
6
# package are under the same license as the package itself.
7
#
8
# Please submit bugfixes or comments via http://bugs.opensuse.org/
9
#
10
11
%define pkgname serdisplib
12
%define libname libserdisp
13
%define soname %{libname}1
14
Name: %{soname}
15
BuildRequires: gd-devel
16
%if 0%{?suse_version} > 1020
17
BuildRequires: libusb-devel
18
%else
19
BuildRequires: libusb
20
%endif
21
License: GPL v2 or later
22
Group: System/Libraries
23
Version: 1.97.9
24
Release: 1
25
Source0: %{pkgname}-%{version}.tar.bz2
26
URL: http://serdisplib.sourceforge.net
27
BuildRoot: %{_tmppath}/%{name}-%{version}-build
28
Summary: Library for Certain Serial and Parallel LC Displays
29
30
%description
31
This is a library with support for certain serial and parallel LC
32
displays connected to the parallel port (and also serial port with i2c
33
displays).
34
35
36
37
Authors:
38
--------
39
Wolfgang Astleitner <mrwastl@users.sourceforge.net>
40
41
%package -n %{libname}-devel
42
Summary: Development environment for serdisplib
43
Group: System/Libraries
44
Requires: %{soname} = %{version}
45
%if 0%{?suse_version} > 1020
46
Requires: libusb-devel
47
%else
48
Requires: libusb
49
%endif
50
51
%description -n %{libname}-devel
52
This package contains the include-files and static libraries for
53
serdisplib
54
55
56
57
Authors:
58
--------
59
Wolfgang Astleitner <mrwastl@users.sourceforge.net>
60
61
%package -n %{pkgname}-tools
62
Summary: Serdisplib Tools (testserdisp, multidisplay)
63
Group: Productivity/Multimedia/Other
64
Requires: %{soname} = %{version}
65
Requires: gd
66
67
%description -n %{pkgname}-tools
68
This package contains the tools for serdisplib
69
70
71
72
Authors:
73
--------
74
Wolfgang Astleitner <mrwastl@users.sourceforge.net>
75
76
%prep
77
%setup -n %{pkgname}-%{version}
78
79
%build
80
CFLAGS="$RPM_OPT_FLAGS" \
81
./configure --enable-libusb --prefix=$RPM_BUILD_ROOT/%{_prefix} --libdir=$RPM_BUILD_ROOT/%{_libdir}
82
make
83
84
%install
85
%__make install
86
87
%clean
88
[ "$RPM_BUILD_ROOT" != "/" ] && [ -d $RPM_BUILD_ROOT ] && rm -rf $RPM_BUILD_ROOT
89
90
%post -p /sbin/ldconfig
91
92
%postun -p /sbin/ldconfig
93
94
%files
95
%defattr(-,root,root)
96
%doc doc COPYING HISTORY README TODO
97
%{_libdir}/*.so.*
98
99
%files -n %{libname}-devel
100
%defattr(-,root,root)
101
%{_libdir}/*.a
102
%{_includedir}/serdisplib
103
%{_includedir}/serdisplib/*
104
%{_libdir}/*.so
105
106
%files -n %{pkgname}-tools
107
%defattr(-,root,root)
108
%{_bindir}/*
109
110
%changelog
111
* Sun Aug 12 2007 - tsieden@suse.de
112
- update to release 1.97.6
113
* fixed potential linking problem in src/Makefile (thanks to Bernhard Walle):
114
libserdisp.so is now linked against libusb (if --enable-libusb is set)
115
--> obsoletes patch from Mon Apr 2 11:41:18 CEST 2007
116
* enhancements / bug-removals in serdisp_tools.c, serdisp_colour.c, testserdisp.s
117
* added support for S1D15G10-based displays in nokcol driver -> driver now uses
118
generic sdtools_generic_get/setpixel() functions
119
* added support for PCF8511-based displays in PCD8544 driver
120
* backported the following displays/controllers (from current devel version):
121
* Osram Pictiva 96X36 OLED 1bit, 1", monochrome
122
* Osram Pictiva 96X64 OLED 16bit, 1", colour
123
* Osram Pictiva 128X64 OLED 4bit, 2.7", greyscale
124
* other minor changes / code beautifyings
125
- fix build (BuildRequires libusb-devel only if suse_version >1020)
126
* Wed May 16 2007 - olh@suse.de
127
- Buildrequires libusb -> libusb-devel
128
* Mon Apr 02 2007 - bwalle@suse.de
129
- added build fix to link library against libusb, important when
130
using dlopen() to use that library.
131
* Fri Mar 09 2007 - tsieden@suse.de
132
- update to release 1.97.5
133
* adapted some driver specs to current devel version
134
* backported the following displays/controllers (from current devel version):
135
* lh155-based displays (eg. Sharp M078CKA 240x64)
136
- only 8080-mode supported for now
137
* E08552 96x32 1bit (controller SED1530)
138
* enhanced t6963-driver
139
* slightly fastened sed133x-driver
140
* Fri Feb 23 2007 - tsieden@suse.de
141
- update to release 1.97.4 (small bugfixes)
142
* Thu Jun 22 2006 - ro@suse.de
143
- remove selfprovides
144
* Thu Apr 13 2006 - tsieden@suse.de
145
- update to release 1.97.2
146
* usb_bulk_read() causes some problems on certain linux-versions
147
* multidisplay: corrected a bug resulting in a wrong background
148
colour when in dithering mode (since v.1.96)
149
* a SONAME is now set in libserdisp (enabled only when using linux)
150
* new displays supported: ericsson r520, ks0108-based,
151
c't includ usb-display
152
* Sat Mar 11 2006 - tsieden@suse.de
153
- fixed build
154
* Fri Mar 03 2006 - tsieden@suse.de
155
- initial release 1.96
156